Add, change, or remove a trendline in a chart

You can add a trendline or moving average to any data series in an unstacked, 2-D, area, bar, column, line, stock, xy (scatter), or bubble chart. A trendline is always associated with a data series, but a trendline does not represent the data of that data series. Instead, a trendline is used to depict trends in your existing data or forecasts of future data.

**NOTE** You cannot add a trendline to data series in a stacked, 3-D, radar, pie, surface, or doughnut chart.

**What do you want to do?**
- Learn about forecasting and showing trends in charts
- Add a trendline
- Change the format of a trendline
- Specify the number of periods to include in a forecast
- Specify the point where the trendline crosses the vertical (value) axis
- Display the trendline equation on the chart
- Display the R-squared value for a trendline
- Remove a trendline

**Learn about forecasting and showing trends in charts**

Trendlines are used to graphically display trends in data and to help analyze problems of prediction. Such analysis is also named regression analysis. By using regression analysis, you can extend a trendline in a chart beyond the actual data to predict future values. For example, the following chart uses a simple linear trendline that is forecasting two quarters ahead to clearly show a trend toward increasing revenue.
You can also create a moving average, which smoothes out fluctuations in data and shows the pattern or trend more clearly.

- If you change a chart or data series so that it can no longer support the associated trendline — for example, by changing the chart type to a 3-D chart or by changing the view of a PivotChart report or associated PivotTable report — the trendline no longer appears on the chart.

- For line data without a chart, you can use AutoFill or one of the statistical functions, such as GROWTH() or TREND(), to create data for best-fit linear or exponential lines.

Choosing the right trendline type for your data

When you want to add a trendline to a chart in Microsoft Office Excel, you can choose any one of these six different trend or regression types: linear trendlines, logarithmic trendlines, polynomial trendlines, power trendlines, exponential trendlines, or moving average trendlines. The type of data that you have determines the type of trendline that you should use.

A trendline is most accurate when its R-squared value is at or near 1. When you fit a trendline to your data, Excel automatically calculates its R-squared value. If you want to, you can display this value on your chart.

Linear trendlines

A linear trendline is a best-fit straight line that is used with simple linear data sets. Your data is linear if the pattern in its data points resembles a line. A linear trendline usually shows that something is increasing or decreasing at a steady rate.

In the following example, a linear trendline illustrates that refrigerator sales have consistently risen over a 13-year period. Notice that the R-squared value is 0.979, which is a good fit of the line to the data.

![Refrigerator Sales Trendline](image)

Logarithmic trendlines

A logarithmic trendline is a best-fit curved line that is used when the rate of change in the data increases or decreases quickly and then levels out. A logarithmic trendline can use both negative and positive values.

The following example uses a logarithmic trendline to illustrate predicted population growth of animals in a fixed-space area, where population leveled out as space for the animals decreased. Note that the R-squared value is 0.933, which is a relatively good fit of the line to the data.
Polynomial trendlines

A polynomial trendline is a curved line that is used when data fluctuates. It is useful, for example, for analyzing gains and losses over a large data set. The order of the polynomial can be determined by the number of fluctuations in the data or by how many bends (hills and valleys) appear in the curve. An Order 2 polynomial trendline generally has only one hill or valley. Order 3 generally has one or two hills or valleys. Order 4 generally has up to three hills or valleys.

The following example shows an Order 2 polynomial trendline (one hill) to illustrate the relationship between driving speed and fuel consumption. Notice that the R-squared value is 0.979, which is a good fit of the line to the data.

Power trendlines

A power trendline is a curved line that is used with data sets that compare measurements that increase at a specific rate — for example, the acceleration of a race car at 1-second intervals. You cannot create a power trendline if your data contains zero or negative values.

In the following example, acceleration data is shown by plotting distance in meters by seconds. The power trendline clearly demonstrates the increasing acceleration. Note that the R-squared value is 0.986, which is an almost perfect fit of the line to the data.
Exponential trendlines

An exponential trendline is a curved line that is used when data values rise or fall at constantly increasing rates. You cannot create an exponential trendline if your data contains zero or negative values.

In the following example, an exponential trendline is used to illustrate the decreasing amount of carbon 14 in an object as it ages. Note that the R-squared value is 0.990, which means that the line fits the data almost perfectly.

Moving average trendlines

A moving average trendline smooths out fluctuations in data to show a pattern or trend more clearly. A moving average uses a specific number of data points (set by the Period option), averages them, and uses the average value as a point in the line. For example, if Period is set to 2, the average of the first two data points is used as the first point in the moving average trendline. The average of the second and third data points is used as the second point in the trendline, etc..

In the following example, a moving average trendline shows a pattern in number of homes sold over a 26-week period.
Add a trendline

1. On an unstacked, 2-D, area, bar, column, line, stock, xy (scatter), or bubble chart, click the data series to which you want to add a trendline or moving average, or do the following to select the data series from a list of chart elements:
   1. Click anywhere in the chart.

   This displays the Chart Tools, adding the Design, Layout, and Format tabs.

2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

   NOTE If you select a chart that has more than one data series without selecting a data series, Excel displays the Add Trendline dialog box. In the list box, click the data series that you want, and then click OK.

3. On the Layout tab, in the Analysis group, click Trendline.

   a. Click a predefined trendline option that you want to use.

      NOTE This applies a trendline without enabling you to select specific options.

   b. Click More Trendline Options, and then in the Trendline Options category, under Trend/Regression Type, click the type of trendline that you want to use.

<table>
<thead>
<tr>
<th>Use this type</th>
<th>To create</th>
</tr>
</thead>
</table>
| Linear        | A linear trendline by using the following equation to calculate the least squares fit for a line:  
   \[ y = mx + b \]  
   where \( m \) is the slope and \( b \) is the intercept. |
| Logarithmic   | A logarithmic trendline by using the following equation to calculate the least squares fit through points:  
   \[ y = c \ln x + b \]  
   where \( c \) and \( b \) are constants, and \( \ln \) is the natural logarithm function. |
| Polynomial    | A polynomial or curvilinear trendline by using the following equation to calculate the least squares fit through points: |
\[ y = b + c_0 x + c_1 x^2 + c_2 x^3 + \ldots + c_n x^n \]

where \( b \) and \( c_0, c_1, \ldots, c_n \) are constants.

**Power**

A power trendline by using the following equation to calculate the least squares fit through points:

\[ y = c x^b \]

where \( c \) and \( b \) are constants.

**NOTE** This option is not available when your data includes negative or zero values.

**Exponential**

An exponential trendline by using the following equation to calculate the least squares fit through points:

\[ y = c e^{bx} \]

where \( c \) and \( b \) are constants, and \( e \) is the base of the natural logarithm.

**NOTE** This option is not available when your data includes negative or zero values.

**Moving average**

A moving average trendline by using the following equation:

\[ y = \frac{d_1 + d_2 + \ldots + d_n}{n} \]

**NOTE** The number of points in a moving average trendline equals the total number of points in the series less the number that you specify for the period.

**R-squared value**

A trendline that displays an R-squared value on a chart by using the following equation:

\[ R^2 = 1 - \frac{SSE}{SST} \]

where

\[ SSE = \sum (y_i - \hat{y}_i)^2 \]

and

\[ SST = \sum (y_i - \bar{y})^2 \]

This trendline option is available on the Options tab of the Add Trendline or Format Trendline dialog box.

**NOTE** The R-squared value that you can display with a trendline is not an adjusted R-squared value. For logarithmic, power, and exponential trendlines, Excel uses a transformed regression model.

If you select **Polynomial**, type the highest power for the independent variable in the **Order** box.

If you select **Moving Average**, type the number of periods that you want to use to calculate the moving average in the **Period** box.
If you add a moving average to an xy (scatter) chart, the moving average is based on the order of the x values plotted in the chart. To get the result that you want, you might have to sort the x values before you add a moving average.

If you add a trendline to a line, column, area, or bar chart, the trendline is calculated based on the assumption that the x values are 1, 2, 3, 4, 5, 6, etc. This assumption is made whether the x-values are numeric or text. To base a trendline on numeric x values, you should use an xy (scatter) chart.

Excel automatically assigns a name to the trendline, but you can change it. In the Format Trendline dialog box, in the Trendline Options category, under Trendline Name, click Custom, and then type a name in the Custom box.

Change the format of a trendline

1. On an unstacked, 2-D, area, bar, column, line, stock, xy (scatter), or bubble chart, click the trendline that you want to change, or do the following to select it from a list of chart elements.
   1. Click anywhere in the chart.
      
      This displays the Chart Tools, adding the Design, Layout, and Format tabs.

   2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

2. On the Layout tab, in the Analysis group, click Trendline, and then click More Trendline Options.

3. To change the color, style, or shadow options of the trendline, click the Line Color, Line Style, or Shadow category, and then select the options that you want.

Specify the number of periods to include in a forecast
1. On an unstacked, 2-D, area, bar, column, line, stock, xy (scatter), or bubble chart, click the trendline that you want to change, or do the following to select it from a list of chart elements.

   1. Click anywhere in the chart.

   This displays the Chart Tools, adding the Design, Layout, and Format tabs.

2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

2. On the Layout tab, in the Analysis group, click Trendline, and then click More Trendline Options.

3. To specify the number of periods that you want to include in a forecast, under Forecast, click a number in the Forward periods or Backward periods box.

Specify the point where the trendline crosses the vertical (value) axis
1. On an unstacked, 2-D, area, bar, column, line, stock, xy (scatter), or bubble chart, click the trendline that you want to change, or do the following to select it from a list of chart elements.
   1. Click anywhere in the chart.

   This displays the Chart Tools, adding the Design, Layout, and Format tabs.

2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

3. Select the Set Intercept = check box, and then in the Set Intercept = box, type the value to specify the point on the vertical (value) axis where the trendline crosses the axis.

   **NOTE**: You can do this only when you use an exponential, linear, or polynomial trendline.

---

**Display the trendline equation on the chart**
1. On an unstacked, 2-D, area, bar, column, line, stock, xy (scatter), or bubble chart, click the trendline that you want to change, or do the following to select it from a list of chart elements.
   1. Click anywhere in the chart.

   This displays the Chart Tools, adding the Design, Layout, and Format tabs.

2. On the Format tab, in the Current Selection group, click the arrow next to the Chart Elements box, and then click the chart element that you want.

3. On the Layout tab, in the Analysis group, click Trendline, and then click More Trendline Options.

3. To display the trendline equation on the chart, select the Display Equation on chart check box.

   **NOTE**: You cannot display trendline equations for a moving average.

**TIP**: The trendline equation is rounded to make it more readable. However, you can change the number of digits for a selected trendline label in the Decimal places box on the Number tab of the Format Trendline Label dialog box. (Format tab, Current Selection group, Format Selection button).
Add, change, or remove a trendline in a chart – Excel – Microsoft Office Online

1. On an unstacked, 2-D, area, bar, column, line, stock, xy (scatter), or bubble chart, click the trendline for which you want to display the **R-squared value**, or do the following to select the trendline from a list of chart elements:
   1. Click anywhere in the chart.

      This displays the **Chart Tools**, adding the **Design**, **Layout**, and **Format** tabs.

   2. On the **Format** tab, in the **Current Selection** group, click the arrow next to the **Chart Elements** box, and then click the chart element that you want.

   3. On the **Trendline Options** tab, select **Display R-squared value on chart**.

      **NOTE** You cannot display an R-squared value for a moving average.

2. On the **Layout** tab, in the **Analysis** group, click **Trendline**, and then click **More Trendline Options**.

   2. Do one of the following:
      - On the **Layout** tab, in the **Analysis** group, click **Trendline**, and then click **None**.
      - Press DELETE.

      **TIP** You can also remove a trendline immediately after you add it to the chart by

clicking Undo on the Quick Access Toolbar, or by pressing CTRL+Z.